HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
bluerock5

XR650L: Won't start unless it's in neautral - What's up?

5 posts in this topic

My XR650L Electric start will only work in neautral. It used to start in any gear when I pulled in the clutch. I checked that the 2 wires are still plugged in the the clutch perch. Any suggestions? Thanks

Share this post


Link to post
Share on other sites

The clutch switch is probably bad. Try disconnecting the wires and jump, (I think it's a normally open switch). If it will start in gear now, either replace the switch, or permanently connect the wires.

Share this post


Link to post
Share on other sites

once spliced together they have to be conected to ground to bypass the switch

Share this post


Link to post
Share on other sites
Have you checked the kick stand saftey switch?

RH

better yet, disconnect it instead of checking it! :naughty:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0