HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
ETP

03 WR450 Neutral Indicator Light Install

8 posts in this topic

Hey guys,

I am mounting a neutral indicator light on my bike and was wondering where the best place to tap into the wiring is. I looked at an older post by ddialogue to get started. (Thanks Dave)

Took the tank off and found a connector up by the radiator. The blue wire goes in then changes colors going out.

Just wanted get some advice on where to tap into the blue wire before I start cutting up this harness.

Thanks.

Share this post


Link to post
Share on other sites

I'm in the process of dual sporting my 426 but don't know if I'm going to use a neutral indicator. I do have to have a high beam indicator but still can't figure out how to make one work easily. Do you have one on your bike...if so what did you do to make it work?

Share this post


Link to post
Share on other sites
I'm in the process of dual sporting my 426 but don't know if I'm going to use a neutral indicator. I do have to have a high beam indicator but still can't figure out how to make one work easily. Do you have one on your bike...if so what did you do to make it work?

My Trickdualsport kit came with a built in high beam indicator.

If you locate the wire which provides the voltage for high beam and put a splice in it, come off of the splice with a second wire and connect it to a 12 volt LED, and then to ground. This assumes your system is 12DC. If its AC, use a 12V incandescent lamp. That should work.

Share this post


Link to post
Share on other sites

Has anyone added a neutral indicator light to a 02 wr426? I have a rekluse auto clutch so it's hard to tell when it's in neutral. I've read a couple threads on disconnecting the wire from the neutral switch to get full power to the coil when in neutral. Can I use that wire if I disconnect it?

Share this post


Link to post
Share on other sites
Hey guys,

I am mounting a neutral indicator light on my bike and was wondering where the best place to tap into the wiring is. I looked at an older post by ddialogue to get started. (Thanks Dave)

Took the tank off and found a connector up by the radiator. The blue wire goes in then changes colors going out.

Just wanted get some advice on where to tap into the blue wire before I start cutting up this harness.

Thanks.

I just pulled the pin from the harness and soldered it to the existing wire, reinserted it into the harness, and then shrunk-wrapped the diode and wires to weather protect them. It's been working great so far.

Yeah, that little green light is cool...in a nerdy kind of way! :D

Share this post


Link to post
Share on other sites
My Trickdualsport kit came with a built in high beam indicator.

If you locate the wire which provides the voltage for high beam and put a splice in it, come off of the splice with a second wire and connect it to a 12 volt LED, and then to ground. This assumes your system is 12DC. If its AC, use a 12V incandescent lamp. That should work.

Sorry to dig up an old thread but I would like to add a neutral light to my 02 426 and my wifes 05 TT-R125.

Stupid question but aren't all bikes 12v DC :thumbsup:

Some threads say you need to add a diode and some say different. Is one really required? :bonk:

Share this post


Link to post
Share on other sites

No help anyone? :thumbsup: come on, i can rebuild an engine blindfolded but am electrically challenged :bonk:

Share this post


Link to post
Share on other sites
Sorry to dig up an old thread but I would like to add a neutral light to my 02 426 and my wifes 05 TT-R125.

Stupid question but aren't all bikes 12v DC :bonk:

Some threads say you need to add a diode and some say different. Is one really required? :thumbsup:

I'm electrically-stupid myself. That's why I turned to TT to help me with my neutral-switch LED. :eek:

As I understand it, the diode will only let voltage flow one direction. I was told this was a necessary thing to install so that voltage isn't accidentally sent to the ignition (oops!)

Don't quote me but the lighting system on our thumpers is AC while the ignition system is DC. You'll be able to do the neutral switch LED mod but the only difference between my bike and yours is that your bike will need to be running to see it.

Good luck! :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0