2 stroke wont rev high??

My sons PW80 won't rev very high no mater in gear or not, it just splutter when it gets to the higher end, this happens just about at half throttle. Bike is completely stock straight out of the box. Any ideas guys Thanks in advance :)

sputtering makes it sound rich. try going 1 size smaller on the main jet and see if that helps. if it's rich enough to not rev high it might need a couple sizes smaller, if that's the problem.

make sure the air filter isn't overoiled too, and there's nothing blocking the intake.

I know the perfect solution. Get him a TTR90. :) You might want to mess with the jetting and go leaner, but Yamaha makes most of their bikes to be uncorked, so I would try that then re-jetting. It would probably make the problem worse, but uncorking and going a couple sizes smaller should be the happy middle.

Pull the exhaust off and look in the neck of it. if it has a washer with a small hole in it discard that and it should run better. PW80 never rev'd up anyway but if that washer is in there it is a :):) . Good luck

my guees is your carb is flooding or your air filt. is cloged if its been runing good before. is is idleing? it could be ignition timing as well.

I've had that problem in 2 stroke engines....not in motorcycles, but repairing small engines...that a crappy, worn out, or super fouled plug can cause this.

Just my .02

~Eric

sorry guys, i should have said i already took that washer out of the head pipe :) and it has been like this since it came from santa brand new in december so i am guessing it is a set up problem rather than something broken.

I am not sure what going up/down sizes means, in hands on how to do it stuff. i know it is the jetting in the carb, but i am just repeating that parrot fashion i don't know what to actually change on the carb :)

It may have 3 months warranty on it , take it back yo your dealer and let them worry it, but it may just be it needs more time to run in as I had this problem with my daughters Pee Wee 80, it took about 3 tanks of fuel before it would rev to a decent level and remember it's not a yz 80 so don't expect it to run like one :)

My sons PW80 won't rev very high no mater in gear or not, it just splutter when it gets to the higher end, this happens just about at half throttle. Bike is completely stock straight out of the box. Any ideas guys Thanks in advance :)

you're jetted too rich or there's an intake/exhaust obstruction (which richens jetting)

is the choke on??

Ok, seems jetting is the way to go 1st, thanks for all the input guys :)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now