TT Decomp plug leaking....

My trick little plug is leaking. Has infact since I installed it. Is this common or did I mess it up. Install seems pretty straight forward....... :cry:

Real men use decompression levers!

All in all, is there a seal that you may have forgot to put on or did you ocer tighten the bolt? Maybe you forgot the copper washer on the bolt.

You probaly need a new rubber seal that the decomp plug kinda pops into.

I know the 02's had the seal because it had the decompresor shaft to seal, but im not certain if the 03,04,05's have it because of not haveing a manual decop. :cry:

All in all, is there a seal that you may have forgot to put on or did you ocer tighten the bolt? Maybe you forgot the copper washer on the bolt.

Whoops I didnt see that, until after I posted!

Ohh well

Is it leaking from the seal or the bolt? Mine leaked from the bolt because the stock bolt is a tad too long for the TT plug. I shortened the bolt a hair and that allowed it to tighten down flush with the head.

Right now it is impossible to tell whether it is leaking from the plug or the bolt since there is oil everywhere. I will clean it thoroughly tomorrow and then see if I can't get it to leak.

Chipstein,

PM me with your mailing address and I'll send you a new lip seal. The plugs are unconditionally garenteed for life. This is only the second plug leak out of 1300+ plugs sold. The other was from a lip seal damaged during installation.

When you receive the new seal seat it on the plug then install both the plug and seal at the same time.

Fritz (Vibeguy)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now