420cc big bore kit for yz400

has someone of you put the 420cc big bore kit on the yz400? as you have been? is the power well distributed? the times of maintenance which are? and does the motor become very delicate or there is no problems?

thanks :cry:

andrea

I did the 420 kit in my bike. No problems at all. Same as stock as far as maintenance, just more power all over. I bought a Wiseco piston and sent the cylinder to US Chrome to bore & plate it. And a Cometic gasket kit since the bore is too large for a stock head gasket.

you may want to think about rebuilding the bottom end if the bike has some miles on it. i had a 425 kit in mine, it ran great but after one season of ice the small end of the rod fractured and sheared the wrist pin. and if you're going to rebuild, then just go with the 426 rod, piston, and cylinder. the 426 rod is stronger and uses a bigger wrist pin, so it won't fit the 400 piston.

and if you're going to rebuild, then just go with the 426 rod, piston, and cylinder. the 426 rod is stronger and uses a bigger wrist pin, so it won't fit the 400 piston.

So the 426 Rod, Piston and Cylinder can all be used in a 400 motor? Is there anything else that needs to be done to make this work or is it all just a direct replacement? Thanks in advance.

Regards,

Lucas G.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now