HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
simon@vic

yz/wr450 motor in a yz426 chassis ???

5 posts in this topic

are the motor mounts the same for the 426 and 450???

If i had both bikes in front of me i could figure it out. but the 426 isn't here.

thx for any info

Share this post


Link to post
Share on other sites

I think you would have to cut down the oil lines. You will have to make new engine sleeves for the swingarm bolt. put I think it should work.

Share this post


Link to post
Share on other sites

I think you would have to cut down the oil lines. You will have to make new engine sleeves for the swingarm bolt. put I think it should work.

Depends on the year. The 98-01 bikes use a 17mm bolt and the 02-04 bikes use a 18mm bolt (think I got the sizes right, but the 02-04 bikes use a 1mm larger bolt) for the swingarm.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0