HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
s3706

engine problem with 2000 426

1 post in this topic

The bike started acting funny and kept stalling on me. I stopped riding for a couple of minutes to let the bike cool off. I tried to start the bike after a couple of minutes and I could not move the kick start with the decompression lever pulled in. The decompression lever was easy to pull. After a couple of minutes of messing with it I was able to kick it over and start the bike but it would only idle for a couple of seconds and then die. After that couple of seconds of idling it did the same thing with the kick start and decompression lever. I seems like it is hanging on something but not sure what it is. When I got it back home I took the valve cover off and checked the timing chain and cams and decompression lever and they all look ok. I also checked the timing and it looks correct. I put it back together and it is doing the same thing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0