HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
madbajan

New 04 WR450.....trouble already!!!!

28 posts in this topic

HI all, well I traded a perfect working KTM for a brand new Yamaha WR450 04 canadian model and it wont run at a steady throttle?? Runs great through the gears, real fast good power everywhere but as soon as i hold a steady throttle it splutters and misses????? Dealer tried exchanging cdi box, changed carb, checked compression, changed jets, leaner/& richer. checked timing, cam timing, did leakdown test, still the problem continues...........I'm ready to trade the thing back in and it has less than sixty miles on it, help aaargh!!!! Oh yeah we did all the exhaust mods too fully plugged, end cap off, total spark arrestor removal.No change at all. happens most at 3rd to half throttle. :devil::thumbsup:

Share this post


Link to post
Share on other sites

Man, that's gotta be frustrating! Keep us posted when/if you figure it out....sounds like you may need to play with jetting, but that's just a guess....good luck!

Share this post


Link to post
Share on other sites

Unplug the TPS and take her for a spin. Let us know what happens.

Share this post


Link to post
Share on other sites

Your needle is too lean. With the exhaust baffle removed it's probably worse. Try a EKP needle in the 4th clip or JD kit. Although I don't think they are affecting your problem if you're riding at sea level I'd go up to at least a 168 main and possibly a 48 pilot jet.

Share this post


Link to post
Share on other sites

I think that this has been dicussed at length on the "Jetting" page.

Most people have come to the conclusion that the Air Control Valve or ACV is the problem.

The spring on the ACV lets the diaphram flutter at even throttle settings.

I removed the diaphram & spring and closed off the ACV with a gasket. I keep the o ring in to insure a complete seal.

No Flutter.

There are reasons why Yamaha did this. Other riders have discussed this at length.

Hope that helps. :thumbsup:

Share this post


Link to post
Share on other sites

I went through this same problem. For me, regardless of the jetting, the problem was the un-restricted exhaust. It would sputter badly at constant throttle settings. Then, I bought an insert, I've had the Vortip and PMB. With either, the sputtering stopped. The unrestricted exhaust throws your jetting -way- off. My bike runs quite good with the jetting in my sig, if I take the baffle out, it runs terrible. This is 426 jetting, I don't know what a 450 needs. I bet if you put some type of baffle in, the problem will be gone. I still have the ACV in.

Share this post


Link to post
Share on other sites

Same problem with my Aussie Model 450. I was really pissed off that out of the dealer the thing ran like a dog. Having said that a guy I know bought the same model and his runs like a dream. Go figure. Anyway, I stuffed around with the jetting quite a bit and have got it running alot better, though not perfect!. The TPS disconnect does help heaps, but I am a bit sceptical about unplugging permanently. Keep trying new jetting senarios and you will get there, eventually. I have settled on a 165 main, 48 pilot, stock needle on 3rd clip and about 1 1/2 turns on the fuel screw.

I will try the 42 pilot that came in the kit though and see if it cleans it up any more. Goodluck! 2 weeks ago I knew nothing about jetting. Do some searches on this site and soon you get the hang of it.

goodluck

Share this post


Link to post
Share on other sites

you guys crack me up with all your WR450F problems. I've had mine since April 2004 250 hard riding desert miles and no one single problem

Share this post


Link to post
Share on other sites

You guys crack me up with all your WR450F problems. I've had mine since April 2004 250 hard riding desert miles and no one single problem

:devil::awww::thumbsup:

Share this post


Link to post
Share on other sites

Well there seems to be a few of us here in the 04WR450 boat. Unfortunatley I had to leave my bike at the dealers in Canada to fix and return home to the caribbean I have an 01 WR 426 here and it runs well, never spluttered at all.I've asked them to put a pipe on the bike and the Baja designes legal kit so only hope they can get it running. we changed the carb, went richer, went leaner, with baffle, without baffle, checked the timing, changed the cdi box, did comp tests, disconnected the tps, did leakdown tests, removed the air valve, ?????? Man what has Yamaha done to the venerable WR? I use mine on fire roads, street, and trail and need it to be smooth at a constant setting. Thanks for all the recommendations so far. the best it ran was needle in 5th clip from top tps disconnected,160 main, 48 pilot, spark arrestor in but baffle removed but it still had a slight hiccup. If I wanted an erratic ride I would have bought a reliable bulletproof two stroke but the whole point of thumping is the smoooooooth regular rythms, like reggae man. :thumbsup:

Share this post


Link to post
Share on other sites

Sounds like a fuel problem...my 03 runs great! No steady-throttle issues whatsoever....and I ride her on the street.

Share this post


Link to post
Share on other sites

Both my riding mates and I have had that trouble where feels like your bike is dieing and missing cruising at 100 k's an hour, but it was instantly fixed with a change in the needle (Australia). Not sure the details of the new (geniune yamaha )needle. I can find out if you want to try it.

Share this post


Link to post
Share on other sites

I would be interested in what needle you used.

I am still not 100% happy with mine.

Mine is the Aussie model too

Share this post


Link to post
Share on other sites

I had the splutter issue at 1/8 - 1/4 throttle after I changed from the stock pipe to the yoshi system. I rejetted the bike with the JD jet kit and found that the blue needle had the splutter but the red needle fixed the problem. BTW the red is leaner in the 1/8-1/4 range. Sounds like a jetting issue, jump on into the jetting forum and get some advice from people like JD who are guns at fixing problems like yours.

Share this post


Link to post
Share on other sites

All you unhappy WR450 owners need to sell your bikes and get something else. :thumbsup: For every one of you there are ten of us that love the WR450! :awww: It is a fantastic reliable bike with a few necessary mods to make it perform at top levels. :devil:

Share this post


Link to post
Share on other sites

All you unhappy WR450 owners need to sell your bikes and get something else. :thumbsup: For every one of you there are ten of us that love the WR450! :devil: It is a fantastic reliable bike with a few necessary mods to make it perform at top levels. :awww:

The best thing I have heard in a long time.

Share this post


Link to post
Share on other sites

Indy's right though. My WR's are by far the best bikes I have owned and they really don't require much tuning or tweaking.

Share this post


Link to post
Share on other sites

Thats a positive approach Indy, Ive owned four WRs this is my fourth and I still own a 426 WR so I know WRs!! I am just experiencing something which my 426 or 400s never did as I ride them all off and on roasd in different places in the world. I have a crf 450 which is also smooth as butter and the problem we are experiencing is only onroad at steady throttle settings. If you can help then help if not.......go riding...... :thumbsup:

Share this post


Link to post
Share on other sites

Like the one guy said just unplug your Throttle position sensor, its on the left side of the carb, a wire comes out and goes to a plug about 4 inchs away. Unplug it there and take it for a ride. If you want more details check my post in the jetting forum. There is no doubt that my WR450 is the best running one of all :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0