Disgusted - Can't get oil reading on dipstick

I was out for a trail ride, some water but not too bad.

Buddies CRF450 made out ok.

Anyway, on way home the engine seemed to be knocking louder that usual.

I drove the rest of the half mile and went home and changed the oil. Lots came out. Filled the oil up, let the bike run for minute, no oil reading on dipstick? Did it again, still nothing.

Any thoughts would be greatly appreciated.

Dealer said if the oil pump wasn't working it would have burnt up.

I don't have a clue why oil isn't getting up to the dipstick area.

Thanks (I'm not the greatest mechanic).Bike only has 500 kilometers on it though, and i change the oil religiously with synthetic.

Check the screen fitting in the bottom of the frame oil tank. Might be blocked :thumbsup:.

How much oil have you or did you put in?

The system will hold 1500 to 1700cc depending how dry you drained it.

Also to validate if the pump is working you can "loosen the oil tube at the head (Right side Above Header next to Carb (Chrome Bolt and Oil Tubing)) just a bit while running." 12mm Wrnch will work

If the pump is working you will get solid oil flow.

How much oil have you or did you put in?

The system will hold 1500 to 1700cc depending how dry you drained it.If the pump is working you will get solid oil flow.

WRONG!! Look at his sig, it's an 03. They only hold a quart....

The manual says to open the check screw at where the oil line feeds the head to make sure it is circulating after an oil change. It also says to run it for several minutes to get the oil into the frame tank.

Lowedog

Yep, you need to bleed it through the screw on the head as Lowdog says!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now