HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

yamaharider426f

engine noise/clutch noise 2001 yz426f

1 post in this topic

I just recently purchased a 2001 yz426f and when I got it the clutch was completely destroyed by the person before me they were missing a friction plate and had 2 steel plates stacked on each other. But the motor sounded good and kicks first kick after a new plug. I installed a new clutch and changed the oil to find the filter and screen completely full of metal shavings assumed they were from the clutch I rode the bike about 2 hours and changed the oil again today I flushed everything out and filled it with 10w-40 conventional. After changing the oil and flushing it I rode it around for 20 minutes or so and began hearing a louder than normal rattling from the engine I have been reading a bunch to find the problem but any suggestions would be great

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now