stevethe

Dirt past the filter using no toil oil

8 posts in this topic

Well on the other bikes I haven't seen dirt either. But they take different filters and you can't see into the air boot. I am not running the screen so you can look right into the air boot.

I just put Belray filter oil on the filter and now when you hold the filter to the light you don't see the little holes through the filter.

Share this post


Link to post
Share on other sites

Are you using no toil and to see it you need to look under the factory screen below the filter.

 

Yeah, pull the filter out and wipe the  actual intake tract with a clean paper towel.

 

Nothing shows up on my towel.

Edited by KRANNIE

Share this post


Link to post
Share on other sites

Yeah, pull the filter out and wipe the  actual intake tract with a clean paper towel.

 

Nothing shows up on my towel.

Humph. Mines not working.

Share this post


Link to post
Share on other sites

Humph. Mines not working.

 

 

Is the air cleaner going back inside the bike after you take it out?

Is it going in convex or concave?

Did you rember to put oil on the actual filter, not just show the bottle of oil to the filter ?

Is the motor running backwards, sucking dirt in through the exhaust?

4 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now