RockerYZWR

Cam Swap Question

58 posts in this topic

I am really considering swapping in an '06 YZ450F exhaust cam when I pull off my valve cover soon to check the valves and replace the timing chain (preventative - about 125 total engine hours and I'm riding it a lot these days).  Can anyone tell me if I need any additional parts for the job, such as the guides (or 'dampers' - parts 9 and 10 in the fische) or circlips (part 3) or anything else, or are those things just replace-as-required type parts that I need to open up and inspect?  I realize I may need to order shims if my valves are out at all, and I'll do that when I know where they are currently with it apart and the new cam installed.  This is my first venture into a modern four stroke motorcycle top end/valve train and just wanted to make sure I order what I need in one shot if possible.  

Side question, does the OEM sell different sized shims or is the aftermarket the most viable option?  I'm not finding them in the Yamaha parts lists.  Thanks for any help.

Here is the parts source I use:

http://www.boats.net/parts/search/Yamaha/Motorcycle/2006/YZ450F%20-%20YZ450FV/CAMSHAFT%20CHAIN/parts.html

Share this post


Link to post
Share on other sites

The cam drops right in, but....

 

You have to modify the decompression pin or the motor won't start.

 

The YZ pin is in a different position than the WR, so the exhaust valve stays open too long.

 

You have to grind off 'just enough' to make it work.

If you search YZ Cam you will find a few threads on the subject.

The problem is, the pin height stock is not consistent, so there is no exact amount to remove

It's trail and error.

 

You need no parts beside wear replacement items.

You time the cams the same as the WR.

1 person likes this

Share this post


Link to post
Share on other sites

Thanks a lot for the reply. I'm tracking the decomp pin issue, although I didn't realize it's in a different position on the YZ cam. But from what I've read, I'll start with taking it down a little less than 1mm and go from there. I also read it's mainly electric start issues with that and kick starting still works?

My original idea was to measure from cam base circle to top of pin on the WR cam, and then make the measurement the same on the YZ cam, but if it's positioned differently, that may not work.

Share this post


Link to post
Share on other sites

Thanks a lot for the reply. I'm tracking the decomp pin issue, although I didn't realize it's in a different position on the YZ cam. But from what I've read, I'll start with taking it down a little less than 1mm and go from there. I also read it's mainly electric start issues with that and kick starting still works?

My original idea was to measure from cam base circle to top of pin on the WR cam, and then make the measurement the same on the YZ cam, but if it's positioned differently, that may not work.

 

Kicking actually spins the motor faster, so the decomp mechanism swings out earlier, and it will start.

Share this post


Link to post
Share on other sites

As much experience as I have with automotive engines and general mechanical knowledge, I am not smart at all on how this decompression function works, but I'm sure I'll figure it out when I tear into it and look at it. Cam ordered today, will be here tomorrow, will likely install on Saturday. Pretty stoked to see and hear how it runs if all goes well.

Share this post


Link to post
Share on other sites

As much experience as I have with automotive engines and general mechanical knowledge, I am not smart at all on how this decompression function works, but I'm sure I'll figure it out when I tear into it and look at it. Cam ordered today, will be here tomorrow, will likely install on Saturday. Pretty stoked to see and hear how it runs if all goes well.

 

All it does is 'extend' the lobe to keep one exhaust valve open a tiny bit, so the motor will spin easily, especially at top dead center.

When the threshold rpm is reached, which is at the minimum firing speed, the mechanism retracts the pin due to centrifigtal force, and the motor runs like normal and starts fully

 

Share this post


Link to post
Share on other sites

Ah, ok - I didn't realize the pin was inline with the lobe. Makes sense. So the YZ cam keeps the exh valve open a little longer and I need it to close sooner? Figuring that since in have to grind/polish a little off. Anyway, it'll be in today and I'll get to it on Saturday probably.

Share this post


Link to post
Share on other sites

Ah, ok - I didn't realize the pin was inline with the lobe. Makes sense. So the YZ cam keeps the exh valve open a little longer and I need it to close sooner? Figuring that since in have to grind/polish a little off. Anyway, it'll be in today and I'll get to it on Saturday probably.

 

The YZ cam position/timing is different than the WR, so the pin is in the 'wrong place' when installed in the WR.

Shortening the pin fixes this.

1 person likes this

Share this post


Link to post
Share on other sites

Im pretty surr you dont have to modify the pin- i have an 06 yz exhaust cam in my bike and it was a drop in and done ordeal

It may be because i installed a yz intake cam as well- idk but i didnt have to modify anything.

At any rate, i swapped the 06 intake cam out for an atv builder series hotcam- its sitting on the shelf in my shop of your interested in it.

Edited by knuckleduster271

Share this post


Link to post
Share on other sites

Im pretty surr you dont have to modify the pin- i have an 06 yz exhaust cam in my bike and it was a drop in and done ordeal

It may be because i installed a yz intake cam as well- idk but i didnt have to modify anything.

At any rate, i swapped the 06 intake cam out for an atv builder series hotcam- its sitting on the shelf in my shop of your interested in it.

What bike do you have and did the electric start still work with the unmodified YZ exhaust cam? I don't believe the intake cam would have anything to do with exhaust decomp, but interesting - everything I've read here indicates it has to be ground about 1mm. Thanks for the offer on the intake cam, I'll think about it (though I've read also it doesn't really gain anything over the WR intake, but I don't know for sure).

Share this post


Link to post
Share on other sites

Im pretty surr you dont have to modify the pin- i have an 06 yz exhaust cam in my bike and it was a drop in and done ordeal

It may be because i installed a yz intake cam as well- idk but i didnt have to modify anything.

At any rate, i swapped the 06 intake cam out for an atv builder series hotcam- its sitting on the shelf in my shop of your interested in it.

 Then you have a 2005 or earlier WR

Share this post


Link to post
Share on other sites

Actually its a 2007- and yes the electric start works fine.

I lnow for a fact they are yz450f cams from an 06 as i researched the part numbers on them.

This is the first ive heard anyone say anything about grinding down the decomp.

crash279 on smj has done a ton of yz cam swaps and i never heard him once mention grinding on one.

Im not sure if the intake cam on the wr could be the reason you would have to grind or not. I know the yz cams are advanced a tooth compared to a wr. With that being said my bike had both yz cams in it when i did the swap- it now has a builder series intake hotcam made for the fuel injected 450 atv's at the moment.

Those 06 cams really woke my bike up- it was a huge noticeable difference.

Edited by knuckleduster271

Share this post


Link to post
Share on other sites

Actually its a 2007- and yes the electric start works fine.

I lnow for a fact they are yz450f cams from an 06 as i researched the part numbers on them.

This is the first ive heard anyone say anything about grinding down the decomp.

crash279 on smj has done a ton of yz cam swaps and i never heard him once mention grinding on one.

Lots and lots of posts on grinding the pin. I read Crash279 kick starts his bike when cold. Most of the time the electric start does not work at least when it's cold. I have a different pin in my 07 and it has the YZ GYTR cams. It did not electric start at all with the YZ pin.

Share this post


Link to post
Share on other sites

Lots and lots of posts on grinding the pin. I read Crash279 kick starts his bike when cold. Most of the time the electric start does not work at least when it's cold. I have a different pin in my 07 and it has the YZ GYTR cams. It did not electric start at all with the YZ pin.

Mine always starts with no problem hot or cold-

As far as him kicking the bike cold i cant say i recall ever hearing him say that. Ive watched countless threads on smj with him building yz spec wrs-

I can recall him giving me some carb tuning advice and stating that "all his blue bikes start like their fuel injection"

Edited by knuckleduster271

Share this post


Link to post
Share on other sites

Actually its a 2007- and yes the electric start works fine.

I lnow for a fact they are yz450f cams from an 06 as i researched the part numbers on them.

This is the first ive heard anyone say anything about grinding down the decomp.

crash279 on smj has done a ton of yz cam swaps and i never heard him once mention grinding on one.

Im not sure if the intake cam on the wr could be the reason you would have to grind or not. I know the yz cams are advanced a tooth compared to a wr. With that being said my bike had both yz cams in it when i did the swap- it now has a builder series intake hotcam made for the fuel injected 450 atv's at the moment.

Those 06 cams really woke my bike up- it was a huge noticeable difference.

 

2006/7/8 yz cams all need the pin ground, unless your retard the timing, which negates the whole purpose...

 

https://www.google.com/search?q=yz+auto+decompression+pin+grind&oq=yz+auto+decompression+pin+grind&gs_l=serp.3..33i21l2.1210.9656.0.9809.22.16.6.0.0.0.181.1686.7j9.16.0....0...1c.1.64.serp..0.13.826...0i22i30.tnzs4qddmwQ

Edited by KRANNIE

Share this post


Link to post
Share on other sites

My timing is yz spec- bike dynod at just shy of 55hp- highly doubt i can pull those numbers with wr timing- my carb is jetted perfectly and the bike starts no problem

Share this post


Link to post
Share on other sites

My timing is yz spec- bike dynod at just shy of 55hp- highly doubt i can pull those numbers with wr timing- my carb is jetted perfectly and the bike starts no problem

 

Then you have a magic cam.

 

I know the Hotcams YZ spec cam for the WR, needs no modfication....but it is not a good cam imho.

1 person likes this

Share this post


Link to post
Share on other sites

The Hot cams for the WR loose most of the bottom end. If you run just the intake hot cam it's better but still loses some bottom end.

Share this post


Link to post
Share on other sites

Im running the hotcam 4239 in/bld series. Its the most radical cam profile they make for the 5 valve 450- its not for a wr or yz- it was made for the fi yfz450r's

Specs on it

Hot Cams Builder Series (4239 in/4240 ex)

Intake Lift(inches/mm): 9.64

Intake Lobe Center (degrees): 106

Intake Duration (degrees at .040"): 254

Intake Open / Close: 21 btc/53 abc

Lobe Separation Angle: 107

Overlap: 46

Comments: Best for modified and oversize engines. HD springs required.

Edited by knuckleduster271

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now