Sputtering and Popping above 1/2 throttle

Well Damn,

Put about 15 slow miles on the bike. Lots of starting and stopping with the little one. Good thing though was bike was nice and hot going so slow and the air temps were hot too. So far no signs of what it has been doing, but I think I need to get out on a saturday morning or early afternoon with the boys and ride at a normal clip for a few hours to see what happens. But at least I put things back together right as it ran great and I have no charging issures. The down side is I think I might have cracked that side cover after swapping stators. I have oil seeping out very very slow. I thought I heard something while I was putting it back on. Everything was evenly torqued back down, but I think I had a hang up and I am pretty certain I am at fault on this one. Anyone know where to get a good replacement that's not going to cost me a fortune?

 

Thanks, Chris

Well Damn,

Put about 15 slow miles on the bike. Lots of starting and stopping with the little one. Good thing though was bike was nice and hot going so slow and the air temps were hot too. So far no signs of what it has been doing, but I think I need to get out on a saturday morning or early afternoon with the boys and ride at a normal clip for a few hours to see what happens. But at least I put things back together right as it ran great and I have no charging issures. The down side is I think I might have cracked that side cover after swapping stators. I have oil seeping out very very slow. I thought I heard something while I was putting it back on. Everything was evenly torqued back down, but I think I had a hang up and I am pretty certain I am at fault on this one. Anyone know where to get a good replacement that's not going to cost me a fortune?

 

Thanks, Chris

 

Cracked where, and how badly.....usually repairable.

I think it is cracked up by the upper right hand corner. My best guess is that I didn't have that smaller (2" diameter) area seated correctly or fully when I started tightenting things. Because when it made the "noise" I was tightening that one bolt that is inside and not exposed.

 

I can't imagine it being terrible but it was enough to leak.

 

What are the techniques to repair this type of damage.

 

Thanks, Chris

I think it is cracked up by the upper right hand corner. My best guess is that I didn't have that smaller (2" diameter) area seated correctly or fully when I started tightenting things. Because when it made the "noise" I was tightening that one bolt that is inside and not exposed.

 

I can't imagine it being terrible but it was enough to leak.

 

What are the techniques to repair this type of damage.

 

Thanks, Chris

 

Depends on what it looks like.

 

If you can get the case mating surfaces to go back to sitting flush enough to seal with a gasket, you can just use JB weld to hold the case together.

 

It's cast magnesium, so it's very difficult to weld...

When I pull it and hopefully find my leak I will try and snap a photo or two and post up.

 

Thanks, Chris

New Crankcase cover installed..........Leak solved............

 

Finally got a camping/riding trip in this holiday weekend.

 

THE STOCK STATOR AND RECTIFIER as of right now have solved my problems. Rode all three days with zero issues. Knock on Wood and fingers crossed my bike is fixed!

 

I wanted to update the thread for any future references and say THANK YOU to all who helped me out. I am no mechanic and I had little time to work on the bike so my posts and test results were very sporadic. Thank you for sticking in there and helping me out!!

 

I was one happy camper this weekend!

 

Cheers, Chris

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now