HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

kebab

blinkers not blinking after rain

6 posts in this topic

Ever since leaving my bike in a small rain my blinkers do not blink. They just stay constant and on; on the correct side, just without flashing. Prior to the rain they worked swell. They are LED Baja designs. Is it possible for the rain to 'short' the electronic flasher? Is my best bet replacing the flasher? Also, on the BD kit, is the flasher the small black box next to the battery behind the headlight? Bike is a 2001 wr426f if that matters. Sorry if I posted incorrectly and thanks in advance.

Share this post


Link to post
Share on other sites

You might be able to get a electronic flasher at the auto parts store to try.

Share this post


Link to post
Share on other sites

Ever since leaving my bike in a small rain my blinkers do not blink. They just stay constant and on; on the correct side, just without flashing. Prior to the rain they worked swell. They are LED Baja designs. Is it possible for the rain to 'short' the electronic flasher? Is my best bet replacing the flasher? Also, on the BD kit, is the flasher the small black box next to the battery behind the headlight? Bike is a 2001 wr426f if that matters. Sorry if I posted incorrectly and thanks in advance.

 

WD-40 every switch and device in the circuit of the turn signals.....sorry, 'blinkers'.....

Share this post


Link to post
Share on other sites

WD-40 every switch and device in the circuit of the turn signals.....sorry, 'blinkers'.....

Thanks, I'll try that out. no apology necessary friend

Share this post


Link to post
Share on other sites

I now with 07 my blinkers stop for no reason,turns out their is 2 parts to the stator Ac n dc, Ac runs lights n wot not dc is battery,auto elec wired lights to dc,no problems,right fix is new stator but all good for now other than head light flashes a bit,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now