Coolant driping from pump housing 98 400f

I have a 98 yz400f that drips coolant from the under side of the water pump housing. It seems to do it most when the bike is first started up. I plan to take the sidecase off and see what is going on. Does anyone have any idea as far as what to look for? I had also heard that 99 pumps are better, is this true?? THANKS Jimmy K

I had the same thing a year ago on my 98. Sounds like you need to replace the seals at the impeller. But be careful taking it apart, the impeller shaft has a square drive end that will break!

I just had the same thing on my '99. When the first seal goes, you get coolant out of the little hole on the bottom of the housing. There are 2 seals on the impeller shaft. replace them both even if one still looks good. They are only a couple of bucks.

You will have to remove the entire crancase (drain the oil!) cover to get at these parts. Taking off the impeller housing only lets you see the impeller itself. I think I paid $3 and $4 for each seal.

Originally posted by Jimmy K:

I have a 98 yz400f that drips coolant from the under side of the water pump housing. It seems to do it most when the bike is first started up. I plan to take the sidecase off and see what is going on. Does anyone have any idea as far as what to look for? I had also heard that 99 pumps are better, is this true?? THANKS Jimmy K

Originally posted by Jimmy K:

I have a 98 yz400f that drips coolant from the under side of the water pump housing. It seems to do it most when the bike is first started up. I plan to take the sidecase off and see what is going on. Does anyone have any idea as far as what to look for? I had also heard that 99 pumps are better, is this true?? THANKS Jimmy K

Hey Jimmy K. I once had a 98 and the pump shaft went bad and caused the seal to start leaking like you described. It is mostly caused by the crank wobbling and slowly wearing the seal out. Maybe that is happening to yours. It is easy enough to put a new seal in. That would probably do the trick, at the very least, for awhile. Yes, the '99 had a better pump, but I believe it's just the shaft that is different. Good luck

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now