Ronnie.sensiba

Cam wear question.. Does this look right?

3 posts in this topic

ImageUploadedByThumper Talk1457166640.222473.jpg

2005 wr450. This is my first time adjusting my own valves or messing with any of that. I noticed a line in the middle of the teeth on the exhaust valve. Are they cast this way or is my cam wearing out there? Intake cam doesn't seem to have this.

Also how difficult should it be to turn the cams over with the chain off. I want to be able to see how healthy my valve train is but I have no clue. Thanks for your input :)

Share this post


Link to post
Share on other sites

attachicon.gifImageUploadedByThumper Talk1457166640.222473.jpg

2005 wr450. This is my first time adjusting my own valves or messing with any of that. I noticed a line in the middle of the teeth on the exhaust valve. Are they cast this way or is my cam wearing out there? Intake cam doesn't seem to have this.

Also how difficult should it be to turn the cams over with the chain off. I want to be able to see how healthy my valve train is but I have no clue. Thanks for your input :)

 

The wear marks on the teeth are normal

Don't guess your way around this stuff

Download a service manual and follow it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now