HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Dklassen

Linkage washer broken new bike

1 post in this topic

I un-crated my new bike today and proceeded to grease the steering head bearings which were almost dry from the factory. Once they were done I moved to the linkage & swing arm bearings. The swing arm bearings were pretty good and the linkage was marginal. I replaced the linkage arm with a longer one from Ride Industries and while torquing up the last nut to the recommended specs I watched the brand new washer break into 5-6 pieces. The nut wasn't even that tight yet and yes the wrench was set properly. I had just done another one with a higher setting and backed the wrench off a few lbs.

Has anyone else experienced this? I have never seen this on any of my other bikes ever. The washer is quite thin but it's the same thickness on the three other bolts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now