Sign in to follow this  
Followers 0
deonded

2015 YZ450F Weep hole leak

3 posts in this topic

So today I started my 2015 YZ up for the first time since like october-novemberish, the bike has about 26.5 hours on it and today i noticed a bunch of coolant leaking out of the weep hole. I stopped the bike, waited a couple mins and it started to leak a tiny bit out of the weep hole and when i revved the engine a small amount of vapor came out the hole but a slow slow drips of coolant. Does this mean my seals are going bad? its annoying because the bike is still new, if they are going bad what do i need to buy to fix this problem and how can i prevent it from happening in the future? I run engine ice in my bike and oil changes every 5 hours. 

Share this post


Link to post
Share on other sites

They aren't going they're gone.  Replace both seals and examine the shaft and bearing carefully.  

 

This isn't uncommon with water pumps in general, actually.  Storage isn't that good for them. 

 

Same old song and dance:

 

http://www.thumpertalk.com/topic/841710-04-450-coolant-leak/

Yeah, I bought a seal and bearing kit today should be here by the end of the week, hopefully my impeller shaft is still good...I mean the bike only has 26.5 hours on it so I don't see how the impeller would be damaged...kinda frustrating that the seal went so soon but oh well its a dirt bike. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0