HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
alexp96

2013 yz450 wont stay on

4 posts in this topic

hi I got 2013 yz450 a few weeks ago. Everything was running right until i let it sit for 4 days and now the bike starts but shuts off to keep it on you have to stay in throttle does anyone know what it might be. A few friend told me it could be the spark plug. but I'm not sure

Edited by alexp96

Share this post


Link to post
Share on other sites

Will it stay running if you use the cold start knob, or just turn the idle up?  

nope just kept shutting off

Share this post


Link to post
Share on other sites

Sounds like a sticking injector.  Check it for codes.  Might try a top tier injector cleaner fuel additive.  Read the instructions on the label and figure when they say a full tank, they mean 16 gallons. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0