bike is destroying carb seals and o rings!?

I have a yz400f and the carb was rebuilt last year and then the seals and o rings went bad. Then i ordered a 450 carb and those went out to. Anyone know why its doing this. 

could it be my carb is just worn out and needs replaced? the slide has side to side play if that helps

could it be my carb is just worn out and needs replaced? the slide has side to side play if that helps

 

Do you use fuel with Ethanol in it?

Do you use fuel with Ethanol in it?

i just use premium at shell. not sure if that has ethanol or not

i just use premium at shell. not sure if that has ethanol or not

 

It might be worth finding out... because ethanol is known to attack seals and fittings in carbs.

It might be worth finding out... because ethanol is known to attack seals and fittings in carbs.

ok but i ran regular not premium in my xr200 and it doesnt have problems. But i guess regular and premium gas probably has different percents of ethanol

Id make sure you arent using e85. It has a higher octane rating so maybe the pump displays 105? Not sure, ive never gotten it. I live in the corn belt and have little choice but to run 10% ethanol without issues. Makes me think you are running 85. Do you use any fuel treatments?

If you are not treating your gas for ethanol, you will continue to have problems, and even worse, internal carb corrosion.

Id make sure you arent using e85. It has a higher octane rating so maybe the pump displays 105? Not sure, ive never gotten it. I live in the corn belt and have little choice but to run 10% ethanol without issues. Makes me think you are running 85. Do you use any fuel treatments?

The premium I get at shell says its a 92 or 93 octane, cant remember. I also live in a farming community. Town only has 4-5 thousand people in it. Rest is just farms. I normally do not use fuel treatments. Last time I put in locus oil fuel cleaner in it shortly after that is when the o rings started going bad. Heres the link for the cleaner. http://www.summitracing.com/parts/luc-10020-1

If you are not treating your gas for ethanol, you will continue to have problems, and even worse, internal carb corrosion.

What do i put in the gas to treat for ethanol and what is internal carb corrosion? Still new to engines and carbs. Im only 16

What do i put in the gas to treat for ethanol and what is internal carb corrosion? Still new to engines and carbs. Im only 16

 

Ethanol attracts moisture

Unabated, it will cause corrosion inside the carb, making it a mess to clean, if even possible.

Use Stabil, or Torco, or PRI-G, or whatever, every single tank full. 

Try to find gas without ethanol. We have several stations here that advertise no ethanol and that's all I use for everything. In addition use startron treatment...it works!

every single tank full. 

This is the very first thing I've ever seen you post that made me say, "Wait, WHAT?!?" I don't know anybody that uses fuel treatment every tank? I do know that the gas seems to go bad within weeks now, where just a few years ago it would last months?

 

Ram, are you using regular carb cleaner spray to clean your carb? (because that stuff will eat your seals too)

Edited by GOOSE 07 YZ450F

This is the very first thing I've ever seen you post that made me say, "Wait, WHAT?!?" I don't know anybody that uses fuel treatment every tank? I do know that the gas seems to go bad within weeks now, where just a few years ago it would last months?

 

Ram, are you using regular carb cleaner spray to clean your carb? (because that stuff will eat your seals too)

no i havent used carb cleaner. just the lucas oil product. also the carb bore is worn out

no i havent used carb cleaner. just the lucas oil product. also the carb bore is worn out

yeah, I caught a little of that in the chat last night...Not much if anything can be done once that's worn out, not even sure about the slide side to side play...But you say you had one rebuilt, and then purchased another one with similar issues? I didn't really catch that part...

yeah, I caught a little of that in the chat last night...Not much if anything can be done once that's worn out, not even sure about the slide side to side play...But you say you had one rebuilt, and then purchased another one with similar issues? I didn't really catch that part...

yea the original is worn out and junk. then the shop ordered a used carb and the o rings went out on that and that carbs slide also has side to side play but not as bad as the original one

I really want to help you out, but keep getting the feeling stuff just isn't adding up...what shop are you talking about? You are saying they rebuilt a carb that was "worn out junk"? and when that didn't work, they ordered you a used carb? but they didn't rebuild that one? :huh: and when you say the "rings went out" what do you mean? they were cracked/worn/leaking, what? What bike symptoms are you experiencing? What have you done to fix the symptoms? Aren't you the guy that said the shop rebuilt your entire motor but then it wouldn't start, but turns out you ran it a little, and then tried to bump start it after the timing was off?

Give up

He wants you to read his mind

Give up

He wants you to read his mind

Haha...Partly out of guilt since I bailed on him in the chat last night out of frustration, I thought I'd give it another shot to help out since he is only 16...But now I feel like we're going to find out he's actually 18 but uses a birth certificate that says he's 16 because of a witness protection program or something, haha...Crazy info keeps popping up after the questions are partially answered.

Ditch the carb altogether and find one from an '05-'09 YZ450F.  You'll be much happier.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now