Help needed 2010 yz450f

my bike starts just not quite as it used to (first kick) when it fires up and ridden it splutters at low revs ? Can anyone help me with this ?

my bike starts just not quite as it used to (first kick) when it fires up and ridden it splutters at low revs ? Can anyone help me with this ?

jettings off?

I've had the same issues. Check the easy things first, exhaust leak (I've had the flange on the header crack and not seen until removal) replace crush gasket, check silencer packing, check for intake leak.

Get a tuner and check for any fault codes. Test sensors per the manuel.

If that doesn't work my ultimate fix was to increase the co level to +5. You'll need the oem fi tool not the gytr tuner to do that. Good luck

Is it all stock?

All stock and I do not fix any of my bikes as I'm

Not mechanically minded just leave it to the experts I'm currently looking for somewhere in Manchester or not far or Manchester UK that I can take my bike to and have tested serviced fixed & all the other essentials anyone recommend anywhere ?

Can anyone suggest the best place for me to take my bike to asap ? And would anyone know why u its spluttering/juddery whilst on a quarter of the throttle but anything more it's ok ?

I'm going to guess valve clearance. Not too many UK guys on here... You're probably best off with your closest yami dealer.

 

It's FI so the getting isn't off...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now