Metal in the oil

I bought a used 01 wr426 this summer from a dealer. The bike had difinitely been used. When I got it, I noticed that it ran extremely hot. On one night ride, I noticed that the head pipe was glowing orange while riding! I had a mechanic check jetting and timing items and he made a few adjustments. Then I went to change the oil and a noticed a lot of metal fragments in the oil filter. Should I dump this piece of s**t, while it still runs? Any imput is welcome. Thanks!!

I bought a used 01 wr426 this summer from a dealer. The bike had difinitely been used. When I got it, I noticed that it ran extremely hot. On one night ride, I noticed that the head pipe was glowing orange while riding! I had a mechanic check jetting and timing items and he made a few adjustments. Then I went to change the oil and a noticed a lot of metal fragments in the oil filter. Should I dump this piece of s**t, while it still runs? Any imput is welcome. Thanks!!

All of the above sounds normal. Welcome, if you do a search you will find these topics have been addressed recently. Check out the WR250 forum, much of the FAQ applies to the 450 as well. Happy reading. :)

hows your clutch? i would say its clutch shavings, if so that aint that big of a deal :):D :D

Thats normal.

Get a magnetic drain plug. :)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now