Sign in to follow this  
Followers 0
yzUSMCf

Yz450f bad backfire..

18 posts in this topic

Hey guys I have a 2014 yz450f and I have a full DR.D system on it with the map that DR.D provided below(I hear they created this map on the Dyno with an o2 sensor and all). Bike is a beast I like the power but she has bad deceleration poping! My buds even bring it up to me I'll try to upload a video shortly so you can hear. Does it pop because it is lean? Will that cause any harm? I would play with it more but i have to take the bike to a shop to tune as i do not have a tuner ,Thanks!

1437097947152.jpg

Share this post


Link to post
Share on other sites

Hard to hear the decel pop over all the dirt hitting the cam from riders passing you, but I've never had decel pop on mine with any map, I'd be checking valves to start with

Share this post


Link to post
Share on other sites

Hard to hear the decel pop over all the dirt hitting the cam from riders passing you

ouch...my ego..
1 person likes this

Share this post


Link to post
Share on other sites

I run that map on my 2015 never had any decel pop

hmmm...wonder if it was made for the 2015 ECU since the base line is different from the 14' and 15'. Hope someone who has a 14 with this map has any imput . It has been about 10 hrs since I have checked the valves and they had barely moved. But still a good chance they need to be adjusted.

Share this post


Link to post
Share on other sites

What fuel are you using? I ask because my '10 would backfire on deceleration when I used gas with ethanol. Never did it with non-ethanol or vp fuel. I'd call Dr.D and ask them about the map, maybe try running all zeroes, stock.

Edited by rickallen124

Share this post


Link to post
Share on other sites

If any of the exhaust pipe fittings, or the gasket at the exhaust manifold junction, are loose and not sealing you will have backfiring also.

1 person likes this

Share this post


Link to post
Share on other sites

Like Rick said, make sure to check your exhaust bolts, fittings, and clamps. Make sure everything is tight and sealing correctly. You will get a decel pop if there is an air leak in your exhaust.

Share this post


Link to post
Share on other sites

What fuel are you using? I ask because my '10 would backfire on deceleration when I used gas with ethanol. Never did it with non-ethanol or vp fuel. I'd call Dr.D and ask them about the map, maybe try running all zeroes, stock.

 

That would be due to the need to run richer jetting with ethanol; high oxygen content, low energy value.  The more is in the fuel, the leaner it will be.

Share this post


Link to post
Share on other sites

Like Rick said, make sure to check your exhaust bolts, fittings, and clamps. Make sure everything is tight and sealing correctly. You will get a decel pop if there is an air leak in your exhaust.

I will check that aswell

Share this post


Link to post
Share on other sites

I just checked my valves

Spec. Intake is .13mm to .20mm

Intake is at .15

Spec. Exhaust .20mm-.25mm

Exhaust is at .23

And the bike has 56 hrs on it now. I checked the header bolts they were not loose but could be tightened slightly so I did. The DR.D exhaust dose not use clamps to attach all the pipes and they all look OK.. So I'm not sure

1437438837698.jpg

1437438856842.jpg

Share this post


Link to post
Share on other sites

Yes. And I did but I've been running this map for the last 15 wish hrs or so and it seemed to get a little bit worse. Just wondering it it will cause any harm beside being annoying

Share this post


Link to post
Share on other sites

The exhaust backfire will harm nothing at all.  You might want to see if a little shot of injector cleaner can clear it up, though.  It could be that it doesn't close all the way and is "drooling".

Share this post


Link to post
Share on other sites

as a couple of guys have said if the bike is running fine the first thing I would be looking for is a leaking seal/joint in the exhaust system .

if it is a leak in the exhaust system this type of back fire will not harm you engine. ever been to a speedway lately and heard a jawa or a gm backfire when they ease of the throttle a little

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0