Sign in to follow this  
Followers 0
miqua343

yz450f dies when twisting throttle open

5 posts in this topic

So fresh rebuild on motor. After warmed up, when u open up throttle the motor dies or pops and dies. Starts right back up. Cams set correct as well as timing. Havent changed anything from original set up. Seems like its responsive when cold but when warm it wont respond. Any suggestions? Thanks

Share this post


Link to post
Share on other sites

Do you have an aftermarket fuel screw? I recently had a similar problem only to find out that after taking the carb off a couple times without fishing out the fuel screw o-ring, the last time the fuel screw went back in it neatly sliced the o-ring... And if the carb is off to check that, check that the accelerator pump is squirting too... Any carb cleaner gets in there and black rubber goo can subsequently be found in all sorts of random places.

Share this post


Link to post
Share on other sites

Do you have an aftermarket fuel screw? I recently had a similar problem only to find out that after taking the carb off a couple times without fishing out the fuel screw o-ring, the last time the fuel screw went back in it neatly sliced the o-ring... And if the carb is off to check that, check that the accelerator pump is squirting too... Any carb cleaner gets in there and black rubber goo can subsequently be found in all sorts of random places.

Share this post


Link to post
Share on other sites

yes I do have an aftermarket fuel screw. I'll make sure that there is nothing is wrong with that. the last time I looked and appeared like the accelerator pump is working but I will double check that as well. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0