Sign in to follow this  
Followers 0
Taxgod4u

Speedo is a big fat liar

8 posts in this topic

2011 WR450, Recently the speedo started to read about 70% too high.  Consistantly, every time I ride, for the full ride.   Anybody know how to tell the speedo that I have a 21" front wheel and not a 12"?  fwiw the bike has a new battery and that did not cause or fix it.  Got to be a setting is off.

Share this post


Link to post
Share on other sites

You probably inadvertently switched it from MPH to KPH. Go back in and reset it back to read in MPH.

Share this post


Link to post
Share on other sites

Bingo!

I had it on KPH,  Did make me feel real fast when I was bombing the single track at 80+. 

Share this post


Link to post
Share on other sites

It's in the manual.

 

An extraordinarily useless response.  Particularly since the wheel size calibration isn't discussed therein, as is implied, so it's not only useless, it's wrong.  When someone has nothing to say, it's usually better to just say that. 

 

OP: If you are missing the manual, here's a link: http://api.viglink.com/api/click?format=go&jsonp=vglnk_14237819556356&key=fd4d0c8927dbf2331e83bbda32ac7c21&libId=d808dceb-e211-49c0-984c-8296c2b9a7bc&loc=http%3A%2F%2Fwww.thumpertalk.com%2Ftopic%2F378677-common-threads-look-here-1st-mods-maintenance-common-issues-and-faqs%2F&v=1&out=http%3A%2F%2Fwww.yamaha-motor.eu%2Feu%2Fservices%2Fowner-manuals%2Findex.aspx&title=Common%20Threads%3A%20Look%20here%201st!%20Mods%2C%20Maintenance%2C%20Common%20Issues%20and%20FAQ%27s%20-%20YZ%20400%2F426%2F450%20-%20ThumperTalk&txt=http%3A%2F%2Fwww.yamaha-mo...uals%2Findex.aspx

 

The multi-function display info is in section 1 on page 1-13 and onward.  Setting Km/H vs. miles is on the first of these pages.   Probably exactly what the problem is. 

Share this post


Link to post
Share on other sites

An extraordinarily useless response.  Particularly since the wheel size calibration isn't discussed therein, as is implied, so it's not only useless, it's wrong.  When someone has nothing to say, it's usually better to just say that. 

 

OP: If you are missing the manual, here's a link: http://api.viglink.com/api/click?format=go&jsonp=vglnk_14237819556356&key=fd4d0c8927dbf2331e83bbda32ac7c21&libId=d808dceb-e211-49c0-984c-8296c2b9a7bc&loc=http%3A%2F%2Fwww.thumpertalk.com%2Ftopic%2F378677-common-threads-look-here-1st-mods-maintenance-common-issues-and-faqs%2F&v=1&out=http%3A%2F%2Fwww.yamaha-motor.eu%2Feu%2Fservices%2Fowner-manuals%2Findex.aspx&title=Common%20Threads%3A%20Look%20here%201st!%20Mods%2C%20Maintenance%2C%20Common%20Issues%20and%20FAQ%27s%20-%20YZ%20400%2F426%2F450%20-%20ThumperTalk&txt=http%3A%2F%2Fwww.yamaha-mo...uals%2Findex.aspx

 

The multi-function display info is in section 1 on page 1-13 and onward.  Setting Km/H vs. miles is on the first of these pages.   Probably exactly what the problem is. 

 

But I DID have something to say, and that is, to go to the manual, so you can re-set up your odometer correctly.

 

You are mean

Share this post


Link to post
Share on other sites

But I DID have something to say, and that is, to go to the manual, so you can re-set up your odometer correctly.

 

You are mean

You must be on the bad behavior list!! :ride:

Share this post


Link to post
Share on other sites

I had the same issue and it had nothing to do with KPH vs MPH.  There is a calibration procedure for the speedometer.  I found it in an adventure bike forum.  If you have not resolved this yet, I will see if I can remember how to do this.  I wound up setting mine to 100 percent and verified it with a gps.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0