2004 WR450 headlight help?

I installed the Tusk enduro kit and control switch to for the headlight hi/low beam. My headlight was different than what they showed on the video (no connector plug in the middle, just a yellow, white and blue wire coming from the harness to a three way plug into the back of the headlight) so I cut the yellow and ran it from the bike to the black switch wire (power to the switch). I then spliced the white switch wire to the yellow in the headlight (lo beam) and the blue switch wire into the blue which runs into the headlight (hi beam). Left black alone running from the bike to the headlight as the ground. I asked Rockymountainatv and they said this sounded correct for my model.

Anyhow, I just fired it. No headlight when off as to be expected. Turn it to lo beam and the headlight comes on. Turn it to hi beam and there is no difference. Stays the same. Not getting the high beam (even if I had the hi/low wires reversed there should still be different light output). Any thoughts? Appreciate any help you can provide!

 

Thanks,

Quinn

Think I might have found the problem. Looks like both the blue and yellow wires run to the SAME portion of the bulb plug. It is a three socket plug. ONly two have metal connectors inside (low beam I am guessing and ground). My guess is a new socket at the end of the wires going into the headlight is needed. I would post a pic but apparently I cant upload from my Mac.

Your right. The bike plug is just power and ground. Grab power from the plug to your handlebar swich then the hi and low beam wires to your bulb (side and middle pole)and the ground off the third pole on bulb to the ground on bike plug. The bike plug won't be used to plug into your bulb any more. Unless you get fancy and tap into the wires behind the plug and add a connector in the open middle slot for the high beam.

Your right. The bike plug is just power and ground. Grab power from the plug to your handlebar swich then the hi and low beam wires to your bulb (side and middle pole)and the ground off the third pole on bulb to the ground on bike plug. The bike plug won't be used to plug into your bulb any more. Unless you get fancy and tap into the wires behind the plug and add a connector in the open middle slot for the high beam.

I was going to buy a new h4 plug and run the wires appropriately. Are you suggesting I just hard wire them to the bulb?

I just made short jumper wires to make the connections from the bikes plug to the handlebar power and light bulb ground to bike plug. Same with the high and low beam wires from harness to bulb. Bullet connectors and flat connectors. The males on the light bulb are wider. Needed some fabrication to open up the females and make it fit. I only use my light temporarily.

Clean way would be to remove hot from bike plug and connect it to handlebar switch then find those 90 degree bend flat connectors that can be used with bike plug and hi/lo wires from handlebar switch. Wouldn't need to do anything with ground. Be able to still use factory plug with bulb

I was going to buy a new h4 plug and run the wires appropriately. Are you suggesting I just hard wire them to the bulb?

So no

Not hard wire. Just bullet connectors for tusk end and flat connectors for bike end

So no

Not hard wire. Just bullet connectors for tusk end and flat connectors for bike end

Gotcha. While I was gone and not looking at the forum I bought a new $3 plug and installed it. Works perfectly. Thanks for the help! 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now