Chain Slider has worn a hole in the swingarm

Don't use aluminum.  It won't last long enough to make you happy (unless it's pretty thick).  I've actually worn out one of the stainless plates I made for mine already and replaced it. 

 

Sand. ;)

Running the stock chain slider or aftermarket?

Running the stock chain slider or aftermarket?

 

Any of them that move in place the way the stock one does.  I use the OEM sliders because they hold up OK and cost a lot less than the aftermarket stuff (not counting the cheap knock off reproductions of the stock part).

I loosened mine up the other day to clean/inspect, and found some wear, maybe 1/16" or so, into the surface. This is on a 50-ish hour WR run mostly in desert. I cut and glued a piece of 22 ga galvanized steel to work as a guard for now. I have a TMD slider on hand that I will eventually install, and then I'll make a more robust guard for the swing arm out of some 16 ga or something. I also used some 3M automotive sticky foam tape between the steel and slider for my quick fix and it doesn't seem to move at all now.

Thanks for posting this, Guy, this is a good issue to stay ahead of.

I loosened mine up the other day to clean/inspect, and found some wear, maybe 1/16" or so, into the surface. This is on a 50-ish hour WR run mostly in desert. I cut and glued a piece of 22 ga galvanized steel to work as a guard for now. I have a TMD slider on hand that I will eventually install, and then I'll make a more robust guard for the swing arm out of some 16 ga or something. I also used some 3M automotive sticky foam tape between the steel and slider for my quick fix and it doesn't seem to move at all now.

Thanks for posting this, Guy, this is a good issue to stay ahead of.

It will be interesting what you experience once you put the TMD one on.  I cannot move mine with my hand, it is solid.  Hopefully it should resolve the issue.

Here's the finished item

 

IMG_2330.jpg

 

IMG_2331.jpg

 

 

 

and with it fitted to the arm

IMG_2332.jpg

 

 

and the slider fitted

IMG_2333.jpg

 

IMG_2334.jpg

 

Hopefully this will solve the issue

 

 

I've been looking at my other bikes' chain sliders and I think the problem with the WR lies in its design (ie a fault)

On all my other bikes (none of which have suffered anything like this), the holes in the slider are round and hence the slider can't move back and forth

On the WR, the holes are slots, which allows the slider to move around and rub the swingarm

 

Easier solution to fix the problem than making the Stainless Steel plate, is to find an aftermarket slider that has round holes and not slots like the Gen Yam has.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now