HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
msliker22

Cooling system pressure help please!

1 post in this topic

I got a 07yz450f and the guy that owned it before me busted the waterpump cover and then instead of buying a new one he siliconed the crap out of the busted one and when I got the bike first thing I did was replace the pump cover and the gasket and the y pipe an gasket that connect to ure hoses that go to ure radiators so yesterday I took the bike up an down the road for the first time and about 3 minutes into the ride coolent started spraying from the cap on top of the radiator so I immediately shut the bike down and pushed it home and put it in the shop for the night then when I went to check it out today and I pulled the cap off and there was still pressure built up it also seemed to be leaking from the bottom of the crank case had anyone had this issue maybe it's clogged up somewhere I'm at a loss of what's happening here any advice would be greatly appreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0