2010 450 subframe fail

So i have a 2010 with a yoshi and since the yoshi only has one mounting hole on the slip on, it puts massive pressure on the tiny little tab that it bolts to. Therefore snapping the tap off and letting the exhaust flap and slap whereever it pleases mid moto >:(

has anyone else had this issue I've had it welded and it snapped right back off so its gone to the welder again to get bulked up with a bracket i built.

But my yoshi is next to destroyed :/

So i have a 2010 with a yoshi and since the yoshi only has one mounting hole on the slip on, it puts massive pressure on the tiny little tab that it bolts to. Therefore snapping the tap off and letting the exhaust flap and slap whereever it pleases mid moto >:(

has anyone else had this issue I've had it welded and it snapped right back off so its gone to the welder again to get bulked up with a bracket i built.

But my yoshi is next to destroyed :/

I beefed my up substantially.

If it snapped off in the square tube area, try making a solid alloy insert to fit inside before you weld it back together. Also drill some holes so you can plug weld to the solid piece for added strength. Get your welder to spend extra time to bulk up the area around where the rear guard bolt threads into as well as this is a weak point.

Cheers

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now