HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
Pudgy_Misfit

04 YZ450F Running Rich on Top w/ Stock Main

5 posts in this topic

Kind of funny, runs pretty good except at the top end I'm stuttering and my buddy says he can smell gas when hes riding behind me... Any ideas??

 

The main is the stock 165. Not really sure where else to check. Thanks!!

Share this post


Link to post
Share on other sites

So, it's worth mentioning the air filter is dirty, the plug is a CR7E not a CR8E and I was riding at a slightly higher altitude.

 

Sounds solved to me, maybe some veteran YZer will come along and lay down the knowledge hammer.

Share this post


Link to post
Share on other sites

Just thought of something, anybody know the stock needle or clip position? I can't imagine I'm totally right.

 

Any pro knowledge hammerers?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0