HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
shadowguyforlorn

Please help 05 yz450

3 posts in this topic

Hey guys please help me out. My bike starts when it's cold but it back fires a lot. It also stalls out after riding if I come to a complete stop. It also runs like crap if the choke isn't on. The shop told me the carb has a crack but they sealed it with jv weld. Any help would be greatly appreciated. Thanks

Share this post


Link to post
Share on other sites

Well the crack is kind of suspect, but if you're sure that's not it, I would say you have a vacuum leak or a clogged/dirty pilot jet. 

Share this post


Link to post
Share on other sites

Well the crack is kind of suspect, but if you're sure that's not it, I would say you have a vacuum leak or a clogged/dirty pilot jet.

Thanks for the reply. How could I check for a leak or unclog the jet and put it back the right way

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0