HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
mikseven

WR 400 Clutch issues and questions

1 post in this topic

Hy everybody,

I present myself. I'm Mik, writing from Italy.

I own a WR400 2001 and I'm very happy with it.

I'm going to race in the Italian Motorally Championship this year.

ImageUploadedByThumper Talk1391870066.017139.jpg

Let's go to the question.

I got this bike last year.

It has Rekluse Z Start mounted on.

i've disinstalled the Rekluse now because the clutch boss is broken.

Now, I can see this situation.

1. The Rekluse Clutch Boss seems to be a Yamaha Part modified by Rekluse. Somebody can confirm that?

2. Intalling the stock clutch i see a little wear on the push rod and on the actuator. I have to install a 1/16 shim in order to get the correct tension. I see that Many people found a bearing ball. Is not my case. Is this a common problem?

3. I see that the 426 clutch is totally different. It has 6 springs and 9 friction plates. Is that clutch compatible with 400? I can buy a complete clutch including basket, boss, plates and pressure plate.

Thanks in advance for your help

Mik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0