HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
Devil1

YZ 400f problems

9 posts in this topic

Hey folks,

I recently acquired a 99 400f and I'm having some issues.

I bought this rebuild kit for the carb

http://pages.ebay.com/link/?nav=item.view&id=190948689497&globalID=EBAY-US

After the rebuild I finally got it started but only with the throttle applied.

So here is what it does.

Starts only with throttle applied.

Backfires while running with light throttle applied

Will not idle.

Will accelerate fine under moderate to full throttle with no backfiring.

I have a YouTube video of the first run you may or may not get a better understanding

Please keep the comments bout the video to yourself It was just the first ride in the subdivision.

Share this post


Link to post
Share on other sites

Sounds like idle is set to low and that you have a partially blocked pilot jet. To start this off what is the elevation and temp in your area?

Share this post


Link to post
Share on other sites

I would start by pulling the bowl off the carb and figuring out what size jets are in it. Do you know how to check the jet sizes and what each jet is?

Share this post


Link to post
Share on other sites

Give us your jetting.

Need

Needle model and clip

Eg OBDTM clip 3rd from top

Main jet

Eg 175

Pilot

Eg 45

Also inspect fuel screw as it could be missing the o-ring.

1 person likes this

Share this post


Link to post
Share on other sites

yes I own a 99 yz400f.

also at sea level.

 

I run ethanol but on petrol I ran a JD jetting kit blue needle, 45 pilot, 165 main

 

you say you have just recently acquired the bike, it is an old bike and likely has worn valves and seats, causing fuel/air mix to leak into exhaust and backfire, clean ur carb well and try a JD jet kit but its most likely a problem in the head

Share this post


Link to post
Share on other sites

yes I own a 99 yz400f.

also at sea level.

 

I run ethanol but on petrol I ran a JD jetting kit blue needle, 45 pilot, 165 main

 

you say you have just recently acquired the bike, it is an old bike and likely has worn valves and seats, causing fuel/air mix to leak into exhaust and backfire, clean ur carb well and try a JD jet kit but its most likely a problem in the head

It had the trans rebuilt a few years ago and at that time the valves were checked and were fine. It hasn't really been run since then as my friend moved across the Us and developed the carb issue. I was turned onto a a part possibly being put in upside down I the carb. Another owner said his did the same thing. I'm unsure of what the part is called.

I'll get the info requested for you guys.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0