HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
dan91

compression issue 99wr400, help would be great

9 posts in this topic

did a top end rebuild on my 99wr400 yesterday new barrel, new piston,new rings,  head serviced, carby serviced everything went back together fine started ok but after about 20 minutes through the break in procedure the bike stalled and has lost some compression.. theres still some compression but doesnt lock up requiring the de comp lever like it usually does, just keeps kicking through and not starting , any help or ideas would be great as we plan to go for a ride next week

 

thanks

Share this post


Link to post
Share on other sites

sorry first time posting, left a few details out, valve clearences are spot on , timing on both cams is spot on to the mark on the crank at TDC,

Edited by dan91

Share this post


Link to post
Share on other sites

behaves like stuck valve or decompressor.

 

Check if lubrication is working by unscrewing head banjo bolt and kicking, till oil comes out.

also try applying engine oil to cylinder wall, through spark plug hole. Sometimes it is needed to connect the oil film into compression.

Share this post


Link to post
Share on other sites

behaves like stuck valve or decompressor.

Check if lubrication is working by unscrewing head banjo bolt and kicking, till oil comes out.

also try applying engine oil to cylinder wall, through spark plug hole. Sometimes it is needed to connect the oil film into compression.

Thanks mate I'll give that a try I don't think its the decomp .. Well it looks like its functioning properly on the out side anyway... Do you know a way to get the shit out from under the valves or do I need the head off again lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0