Sign in to follow this  
Followers 0
KuilaWR450f

07 wr450 not starting

6 posts in this topic

Hey all. I was riding my My 07 wr450 when it all of a sudden spluttered then stalled. Went to use the e start but no ignition light were on and the e start did nothing, no sound or anything. I kicked and kicked having no luck at all. It did the same thing the day before but fired straight after. Help, I need to get back to the trail!

Share this post


Link to post
Share on other sites

Just had a full service and the me me habit said it was good. Only thing is it had a very weak battery if that died would it cause this to happen, even to not kickstart?

Share this post


Link to post
Share on other sites

Just had a full service and the me me habit said it was good. Only thing is it had a very weak battery if that died would it cause this to happen, even to not kickstart?

yes

Battery must be present and working to start.

1 person likes this

Share this post


Link to post
Share on other sites

I have seen this problem come up several times before and I still am a little perplexed.  The bikes with which I am familiar, i.e. several KTM's and a Beta , will still kickstart without a battery so I guess that Yamaha 's must be set up differently.

Share this post


Link to post
Share on other sites

I have seen this problem come up several times before and I still am a little perplexed.  The bikes with which I am familiar, i.e. several KTM's and a Beta , will still kickstart without a battery so I guess that Yamaha 's must be set up differently.

You would need to install a battery eliminator device to have it run without the battery.

Same on all Japanese enduro's. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0