HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
topp38

wr loud popping on decel

8 posts in this topic

hi all,,havent bin on here for a while so hi to everyone,,was out doing an enduro last wk bike was going great,,been siting for a few day so took it out for a run,,it was bacfiring and banging like hell,header glowing red which it has nevr done before,,and flames out the can,,spent the last few days checking everything,,leaks in exhaust ,,changed jets,,checked hotstart ,carb boots ,,and it still the same,,i have fmf powercore 4 standard header.,,and all the free mods done,,im at sea level,,main jet is 165,pilot is 45,and clip 4rth from bottom

tried various size of jets and nothing making any differnce,,im totaly stumped  :banghead: anybody any ideas?? oh and the revs hang hi for about 10secs before they drop to idel to,,

woould the valves couse this as its the only thing i havent checked yet,,,

hope somone can help,,thanks guys

Edited by topp38

Share this post


Link to post
Share on other sites

Pull the pilot jet, fun some large fishing line up the passage above the pilot jet, spray some spray brake cleaner inside that passage (no carb cleaner) to clear it out.

Replace the pilot jet with a BRAND NEW ONE, and then pull your fuel screw, replace the oring, and adjust the fuel screw per the pinned post at the top of the forum.

1 person likes this

Share this post


Link to post
Share on other sites

thanks for the replies lads,krannie a blew all the carb out with airling,,including jets aswell,,then replaced the pilot with another one,,ais not removed

Share this post


Link to post
Share on other sites

thanks for the replies lads,krannie a blew all the carb out with airling,,including jets aswell,,then replaced the pilot with another one,,ais not removed

Then check the link above and inspect your vacuum lines. Especially the small one. Mine burned through right at the head.

Share this post


Link to post
Share on other sites

Did you just repack your FMF prior to it popping, banging, and blowing flames?  If so, I would guess you have too much packing and the exhaust isn't slowing down at all in the can, basically acting like a very open, free flowing exhaust.  Remove some of the packing to allow it to actually do its job, and see if it solves the problem.  I overpacked my FMF once and it did exactly like you are describing.  I re-wrapped the core with about 25% less packing and it was much quieter and didn't have the issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0