'02 426 Engine Noise

On my last ride i noticed a strange noise comming from my engine, so every now and then i hear a grinding noise, its comming from the flywheel side of the engine and it sounds like metal rubbing, and its not consistent, ill hear it for like a split second then it goes away, and il hear it again maybe 5 or 10 minutes later. So its not a constant noise.  It more of a metal on metal rubbing sound.   Any help is appreciated.  and how much oil is behind the flywheel cover? Cause i wanna pull it without making a huge mess

Lay the bike on its right side and you wont loose any oil, I just had to pull my ignition cover because of a bad misfire and noise and found the lower bolt for the pickup missing. I found parts of it stuck to my flywheel and a bit on my magnetic drain plug. I ended up cleaning the flywheel of shavings and since I have lots of spares I swapped in a good used complete stator but not before I put locktite on all the little screws. I could see some damage on the stator and some small marks on the flywheel.

Check your chain for slap.

You would be surprised how often chain noise can be miss interpreted.

Check your chain for slap.

You would be surprised how often chain noise can be miss interpreted.

It can happen when not in motion, just sitting there idleing

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now