Sign in to follow this  
Followers 0
Cowles52

Won't start!

2 posts in this topic

I have a 2010 Yamaha YZ450F. I had some problems with it cutting out while I was riding. I took it into the shop n they told me it was the fuel pump going out. I replaced the fuel pump and the problem was solved. Then about a week later it started doing the same thing. I took it in and they told me the electronic connectors were wet n needed cleaning. So they did and again it ran fine for about a week. Now it just died out on me on the track n won't start back up. Every once in a while it will fire up for about 2 seconds then cut back of again. What in the world could this be?

Share this post


Link to post
Share on other sites

It sounds like your bike has come down with a case of the ratchets. To cure this take a ratchet and drive it back words so the bike can be pleased hahaha. All jokes aside, for an engine to work it needs these basic things.

Air

Fuel

Compression

Electricity

Now I'm more familiar with a simple 2 stroke old bike so I'm not sure about all the fuel injection stuff and electronics. Just go through the basic check list of an engines necessities, or simply have it checked out again buy a specialist.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0