HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
Haychasdad

2011 450 no start and quits

5 posts in this topic

Bike quite running has spark fuel system is cleaned I am at a loss it starts runs a few seconds then quits then will not start where do I start??

Share this post


Link to post
Share on other sites

plugged fuel filter. loose electrical connection. mine did the same thing though, cleaned fuel pump filter and ran great for 5-6 hours then the pump died. look at my past posts for detailed info on the fuel filter.

Share this post


Link to post
Share on other sites

I had 09 did the same thing only sometimes I could take off on it might run fine for 15 min. or so backfire and quit. The very last thing i checked was kill switch and it was a pinched wire going down the handle bars. Had to have come from the factory pinched, and i know of a 010 had a wire under kill switch that was arcing on the bars.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0