Stumped

I have a miss towards the top end of the rev-range,I've tried ,plug,coil,kill switch,carb( replaced),air filter,valve clearances ,(spot on)all electrical connection cleaned,still no joy,any suggestions gratefully received ,

Sorry should have said bike is a 2011 450

Are you sure you are not just hitting the rev limiter?

No it's not the limiter, I've read around some more on the forum and it has been described by others as missing as you roll the throttle on or off at cruising speed,but when I say I've tried so many jetting scenarios ,I really have,have gone back to standard and started over,and I am currently running on a KTM (SPIT) carb jetted to suit as I found the seal on the slide on my carb had expired,am waiting for parts to come,have also tried disconnecting TPS,

possibly too rich. try freeing the ehxhaust and intake for a run to see if it clears it.

check fuel filter ;)

possibly too rich. try freeing the ehxhaust and intake for a run to see if it clears it.

Sorry for being thick when you say freeing the exhaust and in let do you mean increase the gap????

check fuel filter ;)

. I have run the bike on a small test tank,same problem,thanks for the reply

Also noticed when running the bike with no rear subframe and air box we could see fuel mist exiting the rear of the carb, as the bike spluttered , is why I went for valve clearances

You know that when running the bike in neutral, the rev limit is lowered to 6500-7000?

Sorry for being thick when you say freeing the exhaust and in let do you mean increase the gap????

???

Pull out any spark arrestors, quiet tips, etc.. from exhaust pipe. free up the flow. let bike breathe. or just try going down a main jet size

Would low compression cause these symptoms ?????? Next step leak down test! Have been using the bike for the past 18 months doing enduros,motoduros,rally's and some h&h about 3500 miles would this normally need a piston and or rings??????

Would low compression cause these symptoms ?????? Next step leak down test! Have been using the bike for the past 18 months doing enduros,motoduros,rally's and some h&h about 3500 miles would this normally need a piston and or rings??????

YES

Would low compression cause these symptoms ?????? Next step leak down test! Have been using the bike for the past 18 months doing enduros,motoduros,rally's and some h&h about 3500 miles would this normally need a piston and or rings??????

omg... lol

...top for a top end, timing chain, chain tensioner, valve adjustment.

Do a leak down test if you think the valves are leaking, but not a common Wr issue.

Ok leak down test done,all good,going down the stator route ,have managed to find a high output stator so I'm awaiting its arrival,any other thoughts would be welcome, the internals of the engine itself showed no signs of wear,

did you do a WFO chop plug test?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now