HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
troysbama

Shifter will not go up. Please help

6 posts in this topic

Hello everyone,

I apologize in advance for the lengthy read. This is my first time to post and I’m really hoping someone can help me. I’ve searched a couple different ways but haven’t found anything I can directly relate to my problem. I’ve only been into dirt bikes for about 6 months and recently bought a 2007 yz450f (started out on a 06 yz250f which I still have). This bike only had roughly 10-15 hours on it when I bought it. The spokes and wheels still shine, sprockets are hardly even dirty, etc… However, I’m learning quickly a bike that doesn’t get used has its own challenges. The rear collar spring had to be cut off, axle nut cut off, and finally the reason for all my misery, the spark plug was mated to the head and broke in half. Well needless to say, after that I decided to tear the entire bike down and put it back together. There’s one caveat to the tear down. I stopped at splitting the case because the crank had no slop and everything looked good from what I could tell. I left the clutch intact as well. There was no sludge buildup or anything at the bottom of the case. FWIW, I also test drove it before I bought it and it rode good but shifted perfectly. Now onto my problem…

So I bought a top and bottom end gasket kit, replaced all pieces I had access to, and put it all back together. I never started it because after I got it all back together I noticed I left the two dowel pins to the cylinder head out and had already accepted the fact that I had to fix that. Before I did that though I bought a new shifter to install and after installing it I shifted it into first gear. I didn’t apply any more pressure than you normally would to shift into first but it made a little noise as it shifted. I didn’t think much of it since there isn’t any oil in the engine but when I went to put it back into neutral the shifter WILL NOT move even a mm upward from the standard position. It still goes down and back up to middle but just won’t go up beyond that. I know better than to try to force it but I’m just not sure what to do about it. I already have the engine back out to start inserting the dowel pins I boneheadedly forgot the first time around. I’m getting ready to take the clutch apart to get a better look but I didn’t have the socket required to get the bolt off. I think it’s 28mm but my 27mm didn’t feel close so I’m hoping someone can confirm. It’s an 07 so I’m assuming the issue that plagued the 06’s with the bearing doesn’t apply here. Before I go splitting the case, does anyone have an idea what could be wrong? I didn’t have the neutral switch installed when I initially shifted it but I don’t think that would cause any issues (maybe it would?). I would greatly appreciate any help. I really want to ride this thing! Between travel for work, buying all the right tools, and being as meticulous as possible, this thing has been in pieces in my garage for over 5 weeks until this weekend. You can imagined how bummed I was to learn another weekend has passed without being able to ride it.

Share this post


Link to post
Share on other sites

Remove the clutch and have a look. Odds are that the shaft slid to the right while the right side cover was off and has become partially or completely disengaged from its proper location, and/or dropped a part. Look at the manual and a parts fiche to locate the pieces.

Share this post


Link to post
Share on other sites

Thanks for the response. I'll be thrilled if I can fix it without splitting it open. Do you happen to know if a 28mm socket will get the clutch housing off? I have the clutch tool. I just need to know what I should be picking up at Lowes for sockets. I have everything from 6 - 22mm, a 27mm, and a 36mm. Are there any sockets for this bike I should pick up in addition to the clutch socket?

Again, thanks for taking the time to read and help.

Share this post


Link to post
Share on other sites

As I recall, it's 30mm, but it could be 32. Measure it 30mm = 1 3/16", 32 is 1 1/4".

Share this post


Link to post
Share on other sites

I had already left for Lowes before you replied. I picked up a 28, 30, and 32. 30mm is confirmed.It's not like I can't use the others at some point.

The good news is that I spent all of 5 minutes, found out what was wrong, and fixed it. Thanks again for helping. I'm posting a picture in case it helps someone else down the road. I hope all I have to do is attach it. It turns out the clang I heard was the washer/spacer falling down and then pin came out of the guide. I put it back together as shown and the shifter goes up and down perfectly. It's the first easy thing I think I've done to this bike. With a little luck I might even get to ride it this weekend.

IMG_20130408_134609.jpg

Share this post


Link to post
Share on other sites

Just as I thought. Real easy mistake to make once the right side cover and the shifter are both off the engine on the bench.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0