2010 YZF 450 Top end rattle?

Hi Guys,

My 2010 450 developed a top end rattle so I shut down the engine as soon as possible, I stripped it to check cam chain and found one of the links in the cam chain had split and thought to myself thats a lucky find could have been real messy if it had snapped!

I have replaced the cam chain and guide at tensoiner slide but the engine still has the same rattle, I have also tried a manual tensioner and still the same rattle.

Has anybody else had a similar problem or any suggestions what to try next??

Any info will be much appreicated.

these engines are pretty noisy. As long as it runs good, and the engine isn't KNOCKING, then you should be OK.

See if makes difference when pulling clutch. Mine is pretty loud but been that way for a long time. Just a thought

these engines are pretty noisy. As long as it runs good, and the engine isn't KNOCKING, then you should be OK.

I know what you mean with them being a bit noisy, but my concern is that it didn't make the noise until the cam chain issue so i'm unsure if there is something else causing it?

asnyder i have tried reving it with clutch in and its not coming from the clutch, i do have a little bit of noise from the clutch but its more of a rattle i'm gettin just as you open the throttle about 1/8 of a turn then let off is where it seems to happen

any other suggestions?

its more of a rattle i'm gettin just as you open the throttle about 1/8 of a turn then let off is where it seems to happen

If the noise happens only as the throttle is released, or is significantly louder that way, it could indicate a loose rod bearing, wrist pin, or a worn piston, although pistons are usually more likely to "slap" under a load.

If the noise happens only as the throttle is released, or is significantly louder that way, it could indicate a loose rod bearing, wrist pin, or a worn piston, although pistons are usually more likely to "slap" under a load.

the noise does seem to worse on throttle release, it seems to be when you start the bike for the first it seems to be fine then after 30 seconds or so the noise appears as though something could be expanding as it starts to warm up, I think it's looking like I will have to strip the top end and see if I can find anything there,

thanks for the info gray

Well guys, I havebeen real busy and finally got round to stripping the top end.

And the problem was spotted very easily once I got the barrel off, the pin through piston had split in half!!!

There is a very slight line in the conrod where the broken bit has been rotating so it's going to be new rod and piston for me.

I'm still thinking that its pretty strange how I discovered the broken link on cam chain when first trying to find the noise and was thinking gee that was a lucky find!

Thought I'd let you guys know and maybe help somebody else out with similar problem.

Cheers

Wish this mine had been so obvious.(guess maybe it was) My piston is on the high side of clearance with some galling of the wristpin in the piston. Hope this solves mine. Yours and mine shows if it doesnt sound right it aint.

Wish this mine had been so obvious.(guess maybe it was) My piston is on the high side of clearance with some galling of the wristpin in the piston. Hope this solves mine. Yours and mine shows if it doesnt sound right it aint.

worse thing was the engine wasn't that noisy just a little rattle, one things for sure I'm glad I didn't keep riding or I would have been looking at a whole more new parts!!

you are a very lucky dude, i'd go buy some lotto tickets asap. to catch a timing chain that broke but didnt destroy your engine, and a wrist pin crack in the same couple days and not destroy your engine is also pretty fortunate.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now