HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
romano2j

200? RM 125

13 posts in this topic

I bought a bike said to be 2003. I bought a 2003 service manual which was not cheap. I tore the top end apart tonight and the wiseco piston I ordered, seems to be the wrong one, it is a flat top but the one I removed is a dome.

Can anyone help I have a few pictures my phone number is 484 343 5383 if anyone can text or call I'd appreciate it.ImageUploadedByThumper Talk1361932717.984617.jpgImageUploadedByThumper Talk1361932744.058577.jpgImageUploadedByThumper Talk1361932766.242478.jpgImageUploadedByThumper Talk1361932789.807813.jpg

Share this post


Link to post
Share on other sites

Pretty sure 125 pistons from 89-03 are all the same... what brand piston is it.. does it fit the bore/con rod? Single ring?

Share this post


Link to post
Share on other sites

If you aren't sure of the year go look at the VIN number on the frame. The tenth digit should be a 3 if its a 2003.

Share this post


Link to post
Share on other sites

@donmx how can you tell so I know?

Can tell by the front brake mounting/ routing, air box and swing arm, there are a few other ways as well but those are the quick signs. 10th digit in the vin# should be a 3 if it is a 2003

Edited by suzook241

Share this post


Link to post
Share on other sites

Can tell by the front brake mounting/ routing, air box and swing arm, there are a few other ways as well but those are the quick signs. 10th digit in the vin# should be a 3 if it is a 2003

Yep. 2001 swingarm was the same size the whole way. 2002-up had a taper-. Front brake hose routing was different 01-03. The fork gaurds on 04-up had a clamp for the brake house. Earlier models didnt. Different suspension on 01-03. Forks were also a different color on the 04-up showa. Alittle more gold color. Thats the quick easy things.

Share this post


Link to post
Share on other sites

Here's another pic...also I understand the chasis digit for the year says the chasis is an 03 but I'm trying to make sure the motor was not changed at some point ImageUploadedByThumper Talk1361972412.342965.jpg

Share this post


Link to post
Share on other sites

What's the engine number?

Edit: never mind, I found it.

Edited by Peterrides

Share this post


Link to post
Share on other sites

Wiseco makes 2 different pistons for this engine. a GP version and a OEM style. I had this problem also. On 1 of the styles I had to drill 2 oil holes for the exhaust bridge. You can run either 1, only lowers the compression by a little.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0