Sign in to follow this  
Followers 0
Knowledge seeker

Need to confirm if I'm correct

9 posts in this topic

A friend of mine has a '07 YZ450f. He installed a 500 kit with a stroked connecting rod. The bike has hanging idle & also revs slow off idle. Would it need a bigger pilot?. What other variables should I check?. Any help will be greatly appreciated.

Roger

Share this post


Link to post
Share on other sites

Adjust the fuel screw. You can put in a new, same sized (probably 45) pilot if you think it might have a layer of varnish.

FYI, a big bore/stroker usually call for minimal, if any jetting change and even then, LEANER.

Slower rev off of idle could be a factor of it being stroked or because something is too tight.

Share this post


Link to post
Share on other sites

With a hanging idle, the problem is usually due to a lean condition of one kind or other. This can be as simple as a pilot adjustment, or it can be as big a deal as tight intake valves (which dilutes the intake stream by leaking compression and combustion gasses back into the port). Cam timing, air leaks around the engine side of the carb, partially opened hot start valves, or the fouled pilot jet Wm1 mentioned are also suspects.

On the jet, understand that the metering orifice of a number 45 pilot is only .017" in diameter. A film of varnish dried on this that is only .001 thick will effectively change the jet to a #38, and if you don't think that will mess things up, well... With that in mind, read this: http://www.thumpertalk.com/forum/showthread.php?p=8021726#post8021726

Try adjusting the idle first, then work through the rest of it.

Share this post


Link to post
Share on other sites

Update:

We re-checked cam timing, valves clearance, air leaks, hot start valve & they're ok. We increased the pilot size until we went too rich & backed down to a 52 PJ which idle the best at the time. In the main we had a 178 MJ. The bike would take off with a weak bottom end so we tried a 172 MJ & ran better but stil with a lame low end. If its short-shifted when we give it gas is weak even by 250f standards. We also noticed on the stand when we rev it detonates big time with flame outs. Can anyone give us insight as to how to troubleshoot this issue?. I mean the guy put in a 500cc kit with a stroked connecting rod.

Roger

Share this post


Link to post
Share on other sites

Update:

We also noticed on the stand when we rev it detonates big time with flame outs.

can you describe your definition here of detonates? if its really doing that, it could me an ignition timing issue.

Share this post


Link to post
Share on other sites

can you describe your definition here of detonates? if its really doing that, it could me an ignition timing issue.

+1

Definately timing. Especially if it backfires when the throttle is let off (carby pops). It also decribes the lean condition as it will be firing on the intake valves & drying the fuel out.

VERY common issue!

Happened on a mates bike after he rebuilt it......only took one ride for me to diagnose it as it goes like crap.....gets hot......carby pops.......backfires.....lean......hard to start ect.

When checking timing you must rotate the engine & check the timing again.

Oh...you may want to change your head gasket & base gasket (maybe base o-ring) as you have most likely blown them or close to it. (if you have gone further than a quick ride down the road ie. a klm or so, or had it running awhile.)

Edited by Barra8

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0