HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
yz426ryda

yz 426 throttle shaft sticking at tps

1 post in this topic

2002 YZ 426 stock everything except for auto decompression exhaust cam from hot cams

I completely rebuilt my carb and am know experiencing the throttle sticking. The problem does not appears to be with the spring, throttle tube or cable. The trottle shaft seats into the TPS and when it does the throttle shaft then becomes sticky, it still moves but the spring does not cause the throttle to snap back. The throttle can be easily be reduced by hand however as it is just sticky, not stuck. If I pull the throttle shaft out a little, from from the TPS boot, the throttle snaps back as it should.

Any ideas?

Is there a particular type of lube that should be used inside the TPS where the throttle shaft seats, if any?

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0