WR400 Water Pump Seal replacement Question/recomendation?


No replies to this topic
  • freeriders98

Posted November 28, 2012 - 09:21 AM

#1

So I have a 99 WR400, its plated with sumo's and I ride it 30 miles a day. Has been doing awesome. However recently I noticed it leaves a bit of a milky oil spot. (has always left an oil spot from the crankcase vent tube) I also noticed that the water pump has coolant coming out of the weep hole. From what it looks like the coolant runs down the frame and makes contact with the oil from the vent tube. I just changed my oil to make sure, oil came out looking clean no milkyness at all

So my question is I know I need to replace the 2 water pump seals. However I don't have the $100 right now to replace the seals, impeller, shaft, bearing and oring. Am I ok to ride it as long as I keep and eye on oil and coolant? Hold off till after the holidays and do it all. Or just order the seals and do the seals now, and possibly have to go in to replace the impeller and shaft later.

It is my sole mode of transportation so I would rather fix the problem right if it is going to cause catastrophic problems. But if it is harmless to let it weep for another month and a half then I would rather do that and put all new parts in.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.