07 yz450f new piston wont start?


4 replies to this topic
  • cochlinfastestyaminwales:)

Posted November 03, 2012 - 07:43 AM

#1

Hi all,
just fitted new cosworth piston kit and cam chain....bike wont start.
have good compression, good spark and fuel.
every few kicks the bike backfires which gives me impression theres an ignition timing issue, however, i havnt touched anything to change ignition timing, i removed the magneto to change the cam chain but looking for any help if this is something simple that ive missed. ive tried putting tiny amount of fuel in the barrel but still nothing, doesnt make sense to me.
please can anyone help because im on the verge of buying a ktm and no1 in theyre right mind wants to do that :p lol

  • stevethe

Posted November 03, 2012 - 08:02 AM

#2

Hi all,
just fitted new cosworth piston kit and cam chain....bike wont start.
have good compression, good spark and fuel.
every few kicks the bike backfires which gives me impression theres an ignition timing issue, however, i havnt touched anything to change ignition timing, i removed the magneto to change the cam chain but looking for any help if this is something simple that ive missed. ive tried putting tiny amount of fuel in the barrel but still nothing, doesnt make sense to me.
please can anyone help because im on the verge of buying a ktm and no1 in theyre right mind wants to do that :p lol


Yea you have a point on the ktm.
Take off the valve cover & go back over your cam timming. Look at the book. Your probably a tooth off.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • cochlinfastestyaminwales:)

Posted November 03, 2012 - 08:06 AM

#3

the dots are perfectly aligned with the top of the head as in the manual.ill try looking for some pics maybe it is a tooth off, didnt think of that cheers.

  • cochlinfastestyaminwales:)

Posted November 04, 2012 - 09:21 AM

#4

took the head off again one of the oil rings was bent luckily didnt scratch the barrel, compression wasnt there. jobs done now shes ready to rip :)

  • Procircuit386

Posted November 04, 2012 - 09:24 AM

#5

All it takes is one tooth off on that cam... recheck your timing. 99% of the time a bike doesnt run with a new top end is timing. So simple, but a pain.





Related Content

Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Forums
Photo

Is it worth it? (Cam and High compression piston) by macgi77


Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies
Forums
Photo

YZ450F 03 Sparks driving me crazy by SirAttard


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies
Wiki
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info


Articles
  • 0 replies
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • - - - - -
  • 0 reviews
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.