How to test headlight?

3 replies to this topic
  • Bandit9

Posted November 03, 2012 - 07:20 AM


Here is the situation. I'm trying to reinstall the Trick Dual Sport kit back on my 09 WR450 that was on it when I first bought it. Everything worked before I removed it. I don't have any instructions, their website doesn't have the kit I have listed. I have everything wired up, and everything works except the damn headlight. The tail light works, brake light, signals work, horn, etc. I'm getting no power to the wires coming out the little Trick DS control box thingy going into the 3 pin headlight plug. I took out the bulb, and it appears to be fine, no broken filaments.

How do I test the bulb to see if it indeed isn't messed up? I tried hooking a wire directly the + on battery to the low beam pin, then another to the - on battery to the ground pin on the 3 pin plug coming out the headlight. Nothing lit up.

Is there another way to test the bulb? I can't find a new H6M bulb local and will have to order.

  • miweber929

Posted November 03, 2012 - 08:18 AM


Resistance measurement on an ohm meter; a bulb should be almost a dead short (or very low resistance) if its good, or you'll get an open (infinite residtance) if its bad across the terminals you described.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Bandit9

Posted November 04, 2012 - 06:32 AM


No ohm meter. I'm not real sharp on circuits and stuff. I guess the question I have now is that if I get a new bulb and put it in, how is that magically going to make the wires start getting power? Seems to me that regardless of the fact that the bulb is bad or good, I still should be getting power to the hi/low beam wires.

Also, the stock set up runs the light on AC, so with the motor running, I should have power coming out of the stock plug that plugs into headlight, and there is no power on that plug with the motor running.

  • Bandit9

Posted November 04, 2012 - 09:31 AM


Correction, the stock plug is getting power with motor running. And the bulb is good. I put it back in stock configuration and the headlight works. It has to be that Trick Dual Sport circuit board/control box. I'm getting power going in to it and nothing coming out. Gonna box it up and ship it to Dale with Trick DS and let him sort it out.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.