1999 yz 400 new topend rebuild


1 reply to this topic
  • heavyhaul317

Posted September 29, 2012 - 02:37 PM

#1

Well i had my 99 yz 400 topend rebuilt from piston to valves chain cams etc. I went for a ride today and it ran great. but towards the end of the day i started to hear some light valve tap noise. My mechanic told me that it is normal but want to get a second opinion. It starts hot which it never did before and has lots of power!! I love the bike and know its old but it kind f sticks with me. Can anyone help? Thanks

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • heavyhaul317

Posted September 29, 2012 - 02:39 PM

#2

Forgot to add i have about 4 hours on the motor.





Related Content

Forums
Photo

YZ450F 03 Sparks driving me crazy by SirAttard


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies
Forums
Photo

The "going back to the other darkside" adventure... by Monk


Dirt Bike   Make / Model Specific   KTM   250/350/450/505 SX-F & XC-F (4-Strokes)
  • Hot  91 replies
Forums
Photo

yz250x vs 450 4t comparisons (preferably desert riding) needed by JakeNorthrupYZ450F


Dirt Bike   Make / Model Specific   Yamaha   Yamaha 2-Stroke
  • 9 replies
Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.