Trying to revive an 1999 yz400... help would be awesome!

3 replies to this topic
  • stevemorgan728

Posted May 18, 2012 - 12:06 PM


So, I told my buddy I'd try to get his 99 yz400 tuned up, and it's turning out to be a bit of a head ache. He left it sitting outside under a deck all winter(lake tahoe) long with gas in it. Obviously, I started with a full tear down and cleaning of the carb, jets, new spark plug, etc, and got rid of the old gas. It was jetted for sea-level, and we are at 5500ft. so I leaned out the main jet and clip position. The pilot seemed fine at 45, about what I run up here. Also, the fuel screw was stuck big time, the little screw tabs broke off when I tried to back it out. I soaked the shit out it with carb cleaner, and it still wont budge with pliers. So, I don't know where it's set at. The accelerator pump diaphram was totally corroded, so I replaced it with a slightly used one from my 08 yz450's carb. Not an exact match, but fit well(bad idea?). I checked his valves... the intake were spot on, but the exhuast were .05mm tight. Didn't adjust them yet thinking it didn't matter much. Other then that, the muffler is toast, sounds like there is no packing whatsoever, and it's leaking a bit of oil(not sure where yet, that's next of the list). I just want to get it running and idling well for now. It will fire with the choke on no problem, and runs at a high idle with the choke on, but as soon as I start to put the choke in it coughs and dies. Tried turning the idle screw in all the way, and it still dies without the choke.

I'm looking for suggestions as to where to go next..... Thanks!

  • mikewrf18

Posted May 18, 2012 - 12:09 PM


I would clean/replace the pilot jet first off.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • RasmusDK

Posted May 18, 2012 - 01:07 PM


Since you have a 450 standing next to it i would try the carb from that, its plug 'n play, i have one on my 400 and it runs perfect. To me it sounds like your only problem is the 13 year old carb :cry:

  • dbrenize

Posted May 18, 2012 - 02:24 PM


i just got my 98 idleing. i have a fmf pipe on and im running a 48 pilot, and a 17o main. the mid range is rich/lean (i cant tell yet) though and i cant seem to get it diled it in enough to get it to start with the kick starter. pop starts and runs like a dream. but im having it looked at by a mechanic. i also am leaking som oil, from my clutch cover. there is a great jettin data base on these bikes. if ayone knows what my starting problem is let me know.

Related Content


Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

Is the 2016 GYTR Yamaha YZ450F too fast? by Fryboy

Dirt Bike   Special Interest Forums   Pro Racing
  • * - - - -
  • Hot  241 replies

Thinking about Yamaha 250... by Arctic Pride

Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies

First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

Help with 2000 yz426 by weekend woods racer

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  36 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.